Security Notice: Update Your Browser

In an effort to provide the highest level of security for our members, we have disabled connections to AAUW’s secure online services from devices using any Transport Layer Security (TLS) Protocol less than 1.1. Any device that is not using TLS 1.1 or higher will not be able to logon to AAUW’s online services. Today, all recent versions of the major internet browsers (Chrome, Firefox, Opera, Safari, Internet Explorer) support TLS 1.1 and higher. This complies with industry standard secure payment processing and helps to protect your private data.

The chart below shows what O/S (Operating Systems) and browsers support TLS 1.1 & TLS 1.2. Only users of older versions of Internet Explorer, Safari, Chrome, or Firefox as their browser will not have the ability to support TLS 1.1 & 1.2. If you are using an unsupported browser and need to access the Membership Services Database, access your Site Resources branch or state website, make an online donation or submit a membership form, or access other members-only materials on AAUW websites, you will need to install an alternate browser such as Chrome, Firefox, Opera or upgrade to a newer version of the browser and operating system. Links to download alternate browsers are below.


OPERATING SYSTEM / BROWSER VERSION
SUPPORT
TLS 1.1 & 1.2

All Windows O/S using Firefox (versions 36 or greater) or Chrome (versions 41 or greater)
Yes
All Windows O/S using last nine versions of Opera
Yes
All Windows 7, 8, or 10 using Internet Explorer 11
Yes
Windows 7 users using version 9 or 10 of Internet Explorer (**must be manually enabled)
Yes
All Windows Vista using Internet Explorer
No
All Windows XP using Internet Explorer
No
All Mac OS X 10.9 -10.11 using Safari version 7 or greater (Earlier versions or Safari are not supported)
Yes

Questions? Please contact Connect2AAUW.